Bug 53399 - packagemapper maps full path when handleDirSep=true
packagemapper maps full path when handleDirSep=true
Status: RESOLVED FIXED
Product: Ant
Classification: Unclassified
Component: Core
1.8.3
All All
: P2 regression (vote)
: 1.9.0
Assigned To: Ant Notifications List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-06-11 18:29 UTC by Maarten Coene
Modified: 2012-06-17 06:01 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Coene 2012-06-11 18:29:14 UTC
When setting the handleDirSep attribute to 'true' on the <packagemapper>, the full path is transformed into a package, while setting the attribute to 'false', only the '*'-portion of the path is mapped (new behaviour since 1.8.3)

Only the '*'-portion of the path should be handled by the mapper, so this change will break many builds having the handleDirSep='true' property set.

Example:

<packagemapper from="/a/b/*.java" to="*" handledirsep="true"/>

1.8.2: a/b/c/Foo.java -> c.Foo (correct)
1.8.3: a/b/c/Foo.java -> a.b.c.Foo (incorrect)

The behavior when setting handleDirSep to 'false' is unchanged.
Comment 1 Stefan Bodewig 2012-06-17 06:01:57 UTC
fixed with svn revision 1351053