Bug 52469 - Changes in Support of SSH-Tunneling of RMI traffic for Remote Testing
Changes in Support of SSH-Tunneling of RMI traffic for Remote Testing
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
All All
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 48016 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-01-15 12:38 UTC by Brian Ferris
Modified: 2012-01-22 15:57 UTC (History)
2 users (show)



Attachments
Support RMI client port configuration and using loopback interfaces. (2.39 KB, application/octet-stream)
2012-01-15 12:38 UTC, Brian Ferris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Ferris 2012-01-15 12:38:07 UTC
Created attachment 28159 [details]
Support RMI client port configuration and using loopback interfaces.

In order to better support SSH-tunneling of the RMI communication channels used in remote testing, please see the attached patch which makes the following two changes:

1) Just as the RMI ports used for the server component can be specified using "server.rmi.port" and "server.rmi.localport" parameters, introduce a "client.rmi.localport" parameter that can control the RMI port used by the RemoteSampleListenerImpl.  Currently, the port is randomly assigned, which makes it tricky to tunnel traffic to that port over a SSH tunnel.

2) The current behavior of RemoteJMeterEngineImpl is to throw an exception if the remote engine attempts to listen to traffic over the loopback interface.  However, we often need this behavior when tunneling RMI traffic over an SSH tunnel as the remote endpoint will actually be a port on the local machine, which is subsequently tunneled.  To support this functionality, I propose allowing the localhost loopback interface to be used if it has been specified directly using the "java.rmi.server.hostname" parameter.  Thus, we keep the current default behavior of warning the user if their remote endpoint is only listening on the local interface, but allowing users who know what they are doing to specify the local interface if they really want to.
Comment 1 Philippe Mouawad 2012-01-15 14:14:09 UTC
Applied with minor modifications:
- changes.xml
- new property added to jmeter.properties with comment


Thanks for the patch.

Date: Sun Jan 15 14:11:54 2012
New Revision: 1231671

URL: http://svn.apache.org/viewvc?rev=1231671&view=rev
Log:
Bug 52469 - Changes in Support of SSH-Tunneling of RMI traffic for Remote Testing

Modified:
   jmeter/trunk/src/core/org/apache/jmeter/engine/RemoteJMeterEngineImpl.java
   jmeter/trunk/src/core/org/apache/jmeter/samplers/RemoteSampleListenerImpl.java
   jmeter/trunk/xdocs/changes.xml

Date: Sun Jan 15 14:13:34 2012
New Revision: 1231672

URL: http://svn.apache.org/viewvc?rev=1231672&view=rev
Log:
Bug 52469 - Changes in Support of SSH-Tunneling of RMI traffic for Remote Testing

Modified:
   jmeter/trunk/bin/jmeter.properties
Comment 2 Philippe Mouawad 2012-01-15 15:37:38 UTC
Date: Sun Jan 15 15:36:52 2012
New Revision: 1231689

URL: http://svn.apache.org/viewvc?rev=1231689&view=rev
Log:
Bug 52469 - Changes in Support of SSH-Tunneling of RMI traffic for Remote Testing

Modified:
   jmeter/trunk/xdocs/usermanual/remote-test.xml
Comment 3 Philippe Mouawad 2012-01-22 15:57:52 UTC
*** Bug 48016 has been marked as a duplicate of this bug. ***