Bug 52339 - JMeter Statistical mode in distributed testing shows wrong response time
JMeter Statistical mode in distributed testing shows wrong response time
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
All All
: P2 regression (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on: 52125
Blocks:
  Show dependency tree
 
Reported: 2011-12-15 09:17 UTC by Christ
Modified: 2011-12-20 20:51 UTC (History)
1 user (show)



Attachments
JAVA sample script to reproduce the problem (4.99 KB, application/x-zip-compressed)
2011-12-15 15:21 UTC, Christ
Details
JMeter log for Bug 52339 (8.78 KB, application/x-zip-compressed)
2011-12-17 13:53 UTC, Christ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christ 2011-12-15 09:17:59 UTC
Depoly latest JMeter NightBuild on two machines [apache-jmeter-r1214179 15-Dec-2011 02:38]

Steps:
1. Start one machine as JMeter server.
2. Update JMeter client jmeter.properties to use mode=Statistical on another machine.
3. Add JMeter server to remote_hosts
3. Start Jmeter client.
4. Open a http test script with some simple http request [about 20 threads and 20 loop]
5. Run script on JMeter client. [In Aggregate Report: Average response is 32ms and Max response is 145ms]
6. Run same script by JMeter server. [in Aggregate Report: Average response is 1464ms and Max response is 2098ms]

The Statistical mode couldn't get correct response time in distributed testing.

JMeter 2.5.1 release version doesn't have the issue.
Comment 1 Sebb 2011-12-15 10:23:02 UTC
Is it only statistical mode that has the problem?

Does the same problem occur if you replace the HTTP samplers with Java samplers?
This will eliminate the effects of accessing the server from different hosts.
Comment 2 Christ 2011-12-15 13:40:38 UTC
I have verified with Standard,Batch,Hold and Statistical mode. It was only occurred on Statistical mode.
I have justed checked with BeanShell Sampler. Both of HTTP and BeanShell sampler have this problem.
Comment 3 Sebb 2011-12-15 14:30:21 UTC
Can you try with Java Sampler please?

I cannot reproduce the problem.
Comment 4 Christ 2011-12-15 15:21:10 UTC
Created attachment 28075 [details]
JAVA sample script to reproduce the problem
Comment 5 Christ 2011-12-15 15:22:09 UTC
The issue could be reproduced by JavaTest class.
I attached script. It could help you reproduce the issue.
Comment 6 Sebb 2011-12-16 11:40:20 UTC
I'm still not seeing the problem, but have not yet been able to test across two different physical hosts.

Also I don't see anything obvious in the changes to StatisticalSampleSender since 2.5.1.
Comment 7 Christ 2011-12-17 06:48:07 UTC
I have recorded about the problem with video.
And you can download from the URL "http://speedy.sh/RfBCj/JMeter-Bug52339.zip" to review it.[The file size is about 5.14MB. MD5: 43F7E75749DFFC778B7C53864271550A]
I have made it to execution file. You can open it directly to replay it.
Comment 8 Sebb 2011-12-17 11:02:24 UTC
Can you run the Java test sample you provided, and attach the following output:

jmeter.log from client and server systems
JTL file from the run (make sure subsamples are saved).

Also, please do the same for the test run as non-GUI on the server node.
Obviously in that case cannot use Statistical mode.
Comment 9 Christ 2011-12-17 13:53:16 UTC
Created attachment 28082 [details]
JMeter log for Bug 52339

Run_C-S_clientLog.zip and Run_C-S_serverLog.zip is the first run log.
Run_no-GUI_serverlog.zip is the second run log.
Comment 10 Christ 2011-12-17 14:01:41 UTC
The problem is not happened when running as non-GUI on the server node.
jmeter.properties has not been changed on server node.
run command:
jmeter -n -t Sample_JMeterBug_52339.jmx -l runNOGUI-onJMeterServer.jtl
Comment 11 Sebb 2011-12-17 14:21:51 UTC
Thanks for the JTL files - I think I've found the problem.

Try using Summary Report instead of Aggregate Report, and the figures look OK.

Seems that Aggregate report is not allowing for the fact that Statistical results represent multiple samples.

I'll try and post a fix for that shortly.
Comment 12 Sebb 2011-12-17 14:32:25 UTC
Looks like the problem might have been caused by the fix for Bug 52125.

In the meantime, use Summary Report rather than Aggregate Report and the display problem should go away.

Please can you confirm if that fixes the issue?
Comment 13 Christ 2011-12-17 15:43:57 UTC
Revision 1197375 is ok for Aggregate Report.
Comment 14 Christ 2011-12-17 15:47:20 UTC
Summary Report is correct in apache-jmeter-r1214179 build.
Aggregate Report is incorrect in apache-jmeter-r1214179 build.
Comment 15 Sebb 2011-12-20 20:51:32 UTC
Also fixes Bug 52125

URL: http://svn.apache.org/viewvc?rev=1221486&view=rev
Log:
Bug 52339 - JMeter Statistical mode in distributed testing shows wrong response time<

Modified:
   jmeter/trunk/src/jorphan/org/apache/jorphan/math/StatCalculator.java
   jmeter/trunk/src/jorphan/org/apache/jorphan/math/StatCalculatorInteger.java
   jmeter/trunk/src/jorphan/org/apache/jorphan/math/StatCalculatorLong.java
   jmeter/trunk/test/src/org/apache/jorphan/math/TestStatCalculator.java
   jmeter/trunk/xdocs/changes.xml