Bug 52330 - With next-Loop-On-Error after error samples are not executed in next loop
With next-Loop-On-Error after error samples are not executed in next loop
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.5.1
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-12-14 11:56 UTC by bernd.lemmer
Modified: 2011-12-17 23:13 UTC (History)
1 user (show)



Attachments
testplan an log (8.17 KB, application/zip)
2011-12-14 11:56 UTC, bernd.lemmer
Details
More complete Test Case (260.86 KB, application/xml)
2011-12-17 23:11 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bernd.lemmer 2011-12-14 11:56:00 UTC
Created attachment 28070 [details]
testplan an log

The new feature of 2.5 next-Loop-On-Error (Bug 30563 ) is a very very useful one!
    Thank you a lot for that. I tried it immediately, thereby I recognized two little problems:
    First:
        When the thread group starts with an only-once-controller, it doesn't work well.
        Please see <<Thread Group 4b - works not>> for demo.
    Second:
        When the error occurs in the last sample of the thread group, in the next loop only the
        transaction controller and not the samplers are listed in the view result tree as been executed.
        Please see <<Thread Group 4e - works not>> for demo
Comment 1 bernd.lemmer 2011-12-14 12:02:14 UTC
Step to Reproduce:
    Run the testplan in the attachments.
    The testplan is based on <<Test_cases30563.jmx>>
Actual Results:
    After an error occurred, in the next loop only the transaction controller is processed but not any sampler.
Expected Results:
    In the next loop after an error occurred, all samplers should be executed. You can see this by disabling the only-once-controller.
    If or if not an error occurred in the previous loop should not modify the execution sequence of the actual loop.
Build Date & Platform:
    Version 2.5 r1158837
    java.version=1.6.0_29
    Please see attached logfile
Comment 2 Philippe Mouawad 2011-12-14 12:09:35 UTC
Hello,
Feature has completely been rewritten in Trunk version.
I checked your Test plan and cannot reproduce isses using Trunk Version.

You can get nightly build here to test on your side:
https://builds.apache.org/job/JMeter-trunk/lastSuccessfulBuild/artifact/trunk/dist/


Get :
apache-jmeter-r1214179_bin.tgz    
apache-jmeter-r1214179_lib.tgz    

And unzip both then copy lib content into lib folder.

Regards
Philippe
http://www.ubik-ingenierie.com

*** This bug has been marked as a duplicate of bug 51866 ***
Comment 3 bernd.lemmer 2011-12-15 08:39:02 UTC
Hello,
thank you for your answer.
After download the trunk version I saw that the first problem is fixed and works well.
But ...
The second problem, demonstrated in thread group <<Thread Group 4e - works not>> is not yet fixed in my opinion: 
If the error occurs in the last sample of the threadgroup, then every second loop is missed. If the loopcount is 3 or 4, then two loops are executed. If the loopcount is 5, then 3 loops are processed.

I hope, you will be able to reproduce the problem too, if you modify the loopcount of the threadgroup.

Regards,
Bernd
Comment 4 Philippe Mouawad 2011-12-17 23:11:26 UTC
Created attachment 28083 [details]
More complete Test Case
Comment 5 Philippe Mouawad 2011-12-17 23:11:56 UTC
Date: Sat Dec 17 23:08:55 2011
New Revision: 1220300

URL: http://svn.apache.org/viewvc?rev=1220300&view=rev
Log:
Bug 52330 - With next-Loop-On-Error after error samples are not executed in next loop

Modified:
   jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
   jmeter/trunk/xdocs/changes.xml
Comment 6 Philippe Mouawad 2011-12-17 23:13:11 UTC
Hello M. Lemmer,
Thank you for your tests, I reproduced issue.

I think now all cases are fixed, but please take some time to check it works for you and reopen issue if you find there is still a problem.

Regards
Philippe