Bug 52115 - SOAP/XML-RPC should not send a POST request when file to send is not found
SOAP/XML-RPC should not send a POST request when file to send is not found
Status: CLOSED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.5.1
All All
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-10-31 18:31 UTC by Yaroslav
Modified: 2011-11-10 23:23 UTC (History)
1 user (show)



Attachments
TP for the issue (4.08 KB, application/octet-stream)
2011-10-31 18:39 UTC, Yaroslav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav 2011-10-31 18:31:55 UTC
I believe it is an issue for the current release as well.

The problem is when "SOAP/XML-RPC" sample uses "Filename" option - then the request will be shown with "500" error in "View Result Tree" but the request will be sent 4(four) empty requests to specified URL destination in background.

The destination system displays 4 empty incoming requests in its log.

This can be defined by tracking Wireshark as well.

TP will be attached.
Comment 1 Yaroslav 2011-10-31 18:39:39 UTC
Created attachment 27878 [details]
TP for the issue
Comment 2 Yaroslav 2011-10-31 19:27:59 UTC
Similar issue exist for "HTTP request" with "GET" method when "File Path" is being used that points to non-existing file.

Fill free to open new issue for "HTTP" if it not related to this one.
Comment 3 Philippe Mouawad 2011-10-31 20:45:36 UTC
Hello,
You reported bug in version 2.4 of JMeter, this version had a retry count of 3 with HTTPHC3Impl, this explain why you have 4 requests.

Since 2.5.1, this is now 1 (which will make 2 requests).
You can customize this by setting:
httpclient3.retrycount=0


I close issue as invalid.
Comment 4 Yaroslav 2011-11-01 06:25:40 UTC
Sorry, 
My initial description is not quit correct.
If the file does not exist (not found) then the sample is displaying corresponding error about it and is sending empty content few times?

My ER is - if file does not exist then the sample should not send anything.

reopened
Comment 5 Sebb 2011-11-01 12:07:18 UTC
Not sure this counts as bug, but it would be a useful enhancement.
Comment 6 Philippe Mouawad 2011-11-01 13:38:48 UTC
Date: Tue Nov  1 13:32:10 2011
New Revision: 1195990

URL: http://svn.apache.org/viewvc?rev=1195990&view=rev
Log:
Bug 52115 - SOAP/XML-RPC should not send a POST request when file to send is not found

Modified:
   jakarta/jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
   jakarta/jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
   jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/SoapSampler.java
   jakarta/jmeter/trunk/xdocs/changes.xml
Comment 7 Yaroslav 2011-11-03 19:06:58 UTC
r1196526

Verified - when the file does not exists then an error is displayed:

Response code: Non HTTP response code: java.lang.IllegalArgumentException
Response message: Non HTTP response message: Filename references a missing or unreadable file:C:\Projects\LA\AJIS_JIMS\unit_messages\unit_all\data_may14_2011\unit__294695

Works as expected.
Passed 

Can be closed.
Comment 8 Yaroslav 2011-11-03 19:08:29 UTC
For HTTP request - new issue will be opened.