Bug 51996 - JMS Initial Context leak newly created Context when Multiple Thread enter InitialContextFactory#lookupContext at the same time
JMS Initial Context leak newly created Context when Multiple Thread enter Ini...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.5.1
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 52154 (view as bug list)
Depends on:
Blocks: 51691
  Show dependency tree
 
Reported: 2011-10-08 07:59 UTC by Philippe Mouawad
Modified: 2011-11-08 17:56 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2011-10-08 07:59:13 UTC
What will happen is that One thread will create context and store it in MAP.
Others will create a new one but will return the first one and leak the newly created one.
Comment 1 Philippe Mouawad 2011-10-08 08:01:52 UTC
New Revision: 1180335

URL: http://svn.apache.org/viewvc?rev=1180335&view=rev
Log:
Bug 51996 - JMS Initial Context leak newly created Context when Multiple Thread enter InitialContextFactory#lookupContext at the same time

Modified:
   jakarta/jmeter/trunk/src/protocol/jms/org/apache/jmeter/protocol/jms/client/InitialContextFactory.java
   jakarta/jmeter/trunk/xdocs/changes.xml
Comment 2 Sebb 2011-10-08 14:23:08 UTC
Good catch!
Comment 3 Philippe Mouawad 2011-11-08 17:56:50 UTC
*** Bug 52154 has been marked as a duplicate of this bug. ***