Bug 51733 - SyncTimer is messed up if you a interrupt a test plan
SyncTimer is messed up if you a interrupt a test plan
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.5.1
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 52185 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-08-29 05:41 UTC by Rik Gruwez
Modified: 2011-11-15 17:18 UTC (History)
2 users (show)



Attachments
Test Plan to reproduce issue (6.61 KB, application/xml)
2011-10-31 06:10 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rik Gruwez 2011-08-29 05:41:55 UTC
Scenario:
Use a SyncTimer in your test plan and set it to block up to a number of threads, e.g. 5
Run the test and interrupt it before all 5 threads have been blocked. Assume 3 threads have been blocked so far.
Rerun the test and let it run.
You will notice the SyncTimer will unblock after 2 threads and not 5.

The reason is that when the test is started, the clone() method is called on the SyncTimer to created a new one. Since the test interruption left the previous SyncTimer with already 3 threads "registered", this value (3) will be used in the cloned SyncTimer.

Encountered in JMeter 2.5 r1158837
Comment 1 Philippe Mouawad 2011-10-31 06:10:22 UTC
Created attachment 27875 [details]
Test Plan to reproduce issue
Comment 2 Philippe Mouawad 2011-10-31 06:12:11 UTC
Date: Mon Oct 31 06:10:52 2011
New Revision: 1195344

URL: http://svn.apache.org/viewvc?rev=1195344&view=rev
Log:
Bug 51733 - SyncTimer is messed up if you a interrupt a test plan

Modified:
   jakarta/jmeter/trunk/src/components/org/apache/jmeter/timers/SyncTimer.java
   jakarta/jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2011-11-15 17:18:30 UTC
*** Bug 52185 has been marked as a duplicate of this bug. ***