Bug 51715 - Unreadable content opening XSSF generated excel using websphere 7
Unreadable content opening XSSF generated excel using websphere 7
Status: RESOLVED INVALID
Product: POI
Classification: Unclassified
Component: XSSF
3.6
PC All
: P2 critical (vote)
: ---
Assigned To: POI Developers List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-08-24 05:28 UTC by jagadish.b.n
Modified: 2013-08-05 12:22 UTC (History)
1 user (show)



Attachments
attachment file generated using xssf in websphere (4.25 KB, application/xml)
2011-08-29 06:11 UTC, jagadish.b.n
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jagadish.b.n 2011-08-24 05:28:17 UTC
I have been developing excel reports using Apache poi. Initially I have developed reports using HSSF implementation. The HSSF reports opened successfully in office 2003.Later I started converting HSSF reports to XSSF implementation to generate .xlsx report. The web application contaning xlsx reports  when hosted in tomcat server in stand alone system, the reports opened successfully. But same application when hosted in Websphere 7 in client server system does not open the excel report using office 2007. The error pops ups as shown here --- excel found unreadable content in filename.xlsx.Do you want to recover the contents of this workbook? .The list of jar files used in xssf implementation i.e. poi-ooxml-3.6-20091214.jar, poi-ooxml-schemas-3.6-20091214.jar,poi-3.6-20091214.jar, dom4j-1.6.1.jar
Comment 1 jagadish.b.n 2011-08-29 06:11:45 UTC
Created attachment 27444 [details]
attachment file generated using xssf in websphere

The attachment file enclosed is generated in websphere server.I have done few test on xlsx file by zipping it and found the issue in xl\worksheets\sheet1.xml as col width i.e col width="6.696695963541667". the decimals after dot(.) is more than 9. I have reset the decimals with exactly to 9 digits after dot(.) then I was able to open the report the successfully in ms-office 2007.
Comment 2 Nick Burch 2011-08-29 12:53:33 UTC
If you write a small unit test for this, and try to manually set the very long width value, what happens? Is it truncated as needed, or do you still end up with a >9 character width that excel objects to?
Comment 3 jagadish.b.n 2011-09-05 05:35:02 UTC
Hi, We have fixed the below issue by using Servlet outStream to print the data instead of JSP outStream.Thanks,Jagadish
Comment 4 Dominik Stadler 2013-08-05 12:22:41 UTC
seems to have been caused by code outside of poi