Bug 51605 - WebService(SOAP) Request - WebMethod field value changes surreptitiously for all the requests when a value is selected in a request
WebService(SOAP) Request - WebMethod field value changes surreptitiously for ...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.4
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-08-03 07:53 UTC by manuelag2004
Modified: 2011-09-17 16:24 UTC (History)
1 user (show)



Attachments
Synchronize the web methods list with the soap action field (4.62 KB, patch)
2011-09-13 17:55 UTC, benoit.wiart
Details | Diff
Synchronize the web methods list with the soap action field (3.46 KB, patch)
2011-09-16 18:27 UTC, benoit.wiart
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description manuelag2004 2011-08-03 07:53:47 UTC
Overview: In WebService(SOAP) Request:
Whenever a value is selected in the WebMethod drop down list for a request, all the other requests show this value, despite the value specifically selected for them before by the user.
 
Steps to Reproduce: 

1. Choose a web service with at least 2 available methods.
2. Create at least 2 WebService(SOAP) Requests for this web service (with the same WSDL URL and different methods).
3. Choose a new value in WebMethod drop down list for one of the requests.

Actual Results: All the other requests have this value selected in their drop down lists.

Expected Results: The method selected in one request should not have affected the methods selected in the other requests. The selection of a method for one of the requests should leave the other requests unchanged.
Comment 1 Philippe Mouawad 2011-09-12 10:00:53 UTC

*** This bug has been marked as a duplicate of bug 50424 ***
Comment 2 benoit.wiart 2011-09-13 17:52:09 UTC
I don't think this big is a duplicate of 50424
50424 was about mixing webmethods (soap action) of different WSDL
This one is still valid after rev 1169430

the web methods list is not synced with the selected soap action.
While it has no impact on the sampler (which only use the soap action field), the user may think his selection has changed.

I will provide a patch which (when possible) synchronize the list with soap action.
Please note that when the soap action field is empty the user selection in the list will still be lost... as the gui component is shard among all the samplers and is reseted on display.
Comment 3 benoit.wiart 2011-09-13 17:55:26 UTC
Created attachment 27492 [details]
Synchronize the web methods list with the soap action field

I've also expanded the wsdl url input field
Comment 4 benoit.wiart 2011-09-16 18:27:29 UTC
Created attachment 27516 [details]
Synchronize the web methods list with the soap action field

same patch updated to rev 1171338
Comment 5 Milamber 2011-09-17 16:24:08 UTC
Thanks for patch. Applied

URL: http://svn.apache.org/viewvc?rev=1172007&view=rev
Log:
Bug 51605 - WebService(SOAP) Request - WebMethod field value changes surreptitiously for all the requests when a value is selected in a request

Modified:
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/gui/WebServiceSamplerGui.java
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/WSDLHelper.java
    jakarta/jmeter/trunk/xdocs/changes.xml