Bug 50943 - Allowing concurrent downloads of embedded resources in html page
Allowing concurrent downloads of embedded resources in html page
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
Nightly (Please specify date)
PC All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 47817 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-03-17 18:52 UTC by Milamber
Modified: 2012-04-28 14:48 UTC (History)
1 user (show)



Attachments
Patch to concurrent download embedded resources (23.66 KB, patch)
2011-03-17 18:52 UTC, Milamber
Details | Diff
New http requests and http requests defaults elements to docs (53.83 KB, application/x-zip-compressed)
2011-03-17 18:53 UTC, Milamber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milamber 2011-03-17 18:52:28 UTC
Created attachment 26782 [details]
Patch to concurrent download embedded resources

This patch add a option in HTTP Requests (Java mode, HC3/4) and HTTP Requests defaults to get concurrently the embedded resources (css, images, javascript, etc.) in html page.
This may be useful for some tests to try to simulate multiple http connections like a modern browser. (in example: Firefox 3.6 use 6 parallels connections)
Comment 1 Milamber 2011-03-17 18:53:27 UTC
Created attachment 26783 [details]
New http requests and http requests defaults elements to docs
Comment 2 Milamber 2011-03-21 17:24:08 UTC
Applied on SVN.

URL: http://svn.apache.org/viewvc?rev=1083962&view=rev
Log:
Bug 50943 - Allowing concurrent downloads of embedded resources in html page

Modified:
    jakarta/jmeter/trunk/bin/jmeter.properties
    jakarta/jmeter/trunk/docs/images/screenshots/http-config/http-request-defaults.png
    jakarta/jmeter/trunk/docs/images/screenshots/http-request.png
    jakarta/jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jakarta/jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/config/gui/HttpDefaultsGui.java
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/gui/HttpTestSampleGui.java
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
    jakarta/jmeter/trunk/xdocs/changes.xml
    jakarta/jmeter/trunk/xdocs/images/screenshots/http-config/http-request-defaults.png
    jakarta/jmeter/trunk/xdocs/images/screenshots/http-request.png
    jakarta/jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 3 Milamber 2011-03-21 19:35:22 UTC
Thanks to sebb.

URL: http://svn.apache.org/viewvc?rev=1084019&view=rev
Log:
Correct a compiler error with a real JDK 1.5
Bug 50943 - Allowing concurrent downloads of embedded resources in html page

Modified:
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
Comment 4 Philippe Mouawad 2012-04-28 14:48:53 UTC
*** Bug 47817 has been marked as a duplicate of this bug. ***