Bug 50937 - TCP Sampler does not provide for / honor connect timeout
TCP Sampler does not provide for / honor connect timeout
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
unspecified
PC Linux
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-03-16 13:38 UTC by Alex
Modified: 2011-03-18 08:20 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2011-03-16 13:38:51 UTC
It appears that TCPSampler code uses the Socket constructor that does not allow for a connect timeout. The timeout is only set for read operations.
Comment 1 Sebb 2011-03-18 07:38:13 UTC
Seems a reasonable enhancement (it's not a bug)
Comment 2 Sebb 2011-03-18 08:20:33 UTC
URL: http://svn.apache.org/viewvc?rev=1082883&view=rev
Log:
Bug 50937 - TCP Sampler does not provide for / honor connect timeout