Bug 50794 - FOP overflows width when flowing from page-master with wide region-body to narrow (including column-width changes)
FOP overflows width when flowing from page-master with wide region-body to na...
Status: CLOSED WORKSFORME
Product: Fop - Now in Jira
Classification: Unclassified
Component: page-master/layout
0.95
PC Windows Vista
: P2 normal
: ---
Assigned To: fop-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-02-15 23:30 UTC by AMA3
Modified: 2012-04-01 13:42 UTC (History)
0 users



Attachments
stylesheet that demonstrates overflow problem (1.54 KB, text/plain)
2011-02-15 23:32 UTC, AMA3
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AMA3 2011-02-15 23:30:50 UTC
I'm using FOP 0.95 in XMLSpy.

When I flow content from a first page having a simple-page-master onto a second (rest) page having a more narrow region-body, the content on the second page has the same width as the content on the first page, overflowing the body. This also happens if I set the column-count on the second page to be greater than the column-count on the first page.

How do I force the engine to recognize that the available horizontal space has been decreased, and adjust the body (or column) width accordingly?

A stylesheet that demonstrates the problem is attached (use with any XML document that contains sufficient text content to flow from page 1 to page 2).
Comment 1 AMA3 2011-02-15 23:32:07 UTC
Created attachment 26664 [details]
stylesheet that demonstrates overflow problem
Comment 2 Chris Bowditch 2011-02-24 12:12:45 UTC
Hi,

the problem you describe is known as Changing IPD problem. That is a known issue in 0.95. For v1.0 we developed a fix for it that works in most cases. There are some limitations related to lists and tables, but for regular text, upgrading to FOP v1.0 should resolve your problems.

Thanks,

Chris
Comment 3 Glenn Adams 2012-04-01 13:42:56 UTC
batch transition to closed for remaining resolved bugs