Bug 50788 - Project#createTask complains it wouldn't find task componentdef
Project#createTask complains it wouldn't find task componentdef
Status: RESOLVED FIXED
Product: Ant
Classification: Unclassified
Component: Core
1.8.1
All All
: P2 normal (vote)
: 1.8.3
Assigned To: Ant Notifications List
http://mail-archives.apache.org/mod_m...
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-02-15 11:50 UTC by Stefan Bodewig
Modified: 2012-02-05 07:31 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Bodewig 2011-02-15 11:50:23 UTC
I can reproduce the error mentioned on the user list using the example
posted (see URL).
Comment 1 Stefan Bodewig 2011-02-15 11:57:21 UTC
the problem seems to be the fresh Project instance since the error goes away
if the existing instance is reused.  We must implicitly assume some
initialization-step has been performed prior to invoking createTask.
Comment 2 Stefan Bodewig 2012-02-05 07:31:08 UTC
fixed with svn revision 1240669