Bug 50424 - Web Methods drop down list box inconsistent
Web Methods drop down list box inconsistent
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.4
All Windows XP
: P2 major (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-12-07 05:11 UTC by radk
Modified: 2011-09-12 10:00 UTC (History)
3 users (show)



Attachments
Fix to the issue (2.06 KB, patch)
2011-09-08 08:11 UTC, Philippe Mouawad
Details | Diff
WSDL 1 (2.62 KB, application/octet-stream)
2011-09-08 08:12 UTC, Philippe Mouawad
Details
WSDL 2 (2.04 KB, application/octet-stream)
2011-09-08 08:12 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description radk 2010-12-07 05:11:29 UTC
Web Methods drop down list box is inconsistent.

If multiple test plan is created for testing different WSDL services, the web methods drop down list box maintains the previously loaded values. It doesnt get loaded automatically according to the new WSDL test plan.
Comment 1 Philippe Mouawad 2011-09-08 08:10:50 UTC
Hello,
I confirm the bug with following scenario:
- Create a Thread Group
- Add a WebService(SOAP) Request
- Fill WSDL Url 
- Click Load WSDL
- Web Methods is filled
- Add a WebService(SOAP) Request
- Fill ANOTHER WSDL Url 
- Click Load WSDL
- Web Methods is filled
- Go Back to first sampler , you will have methods of other


Analysing this, it is due to the fact that:
- clearGui does not reset wsdlMethods
- configure(TestElement el) does not reload data

I attach a patch and some WSDL for you to check my fix.
DOwnload a Tomcat
Put the 2 WSDL in webapp/ROOT folder
start tomcat by going to <tomcat home>/bin/startup.sh


Regards
Philippe Mouawad
http://www.ubik-ingenierie.com
Comment 2 Philippe Mouawad 2011-09-08 08:11:48 UTC
Created attachment 27473 [details]
Fix to the issue
Comment 3 Philippe Mouawad 2011-09-08 08:12:29 UTC
Created attachment 27474 [details]
WSDL 1
Comment 4 Philippe Mouawad 2011-09-08 08:12:52 UTC
Created attachment 27475 [details]
WSDL 2
Comment 5 Milamber 2011-09-11 12:21:42 UTC
Thanks for the patch. Applied.

URL: http://svn.apache.org/viewvc?rev=1169430&view=rev
Log:
Bug 50424 - Web Methods drop down list box inconsistent

Modified:
    jakarta/jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/gui/WebServiceSamplerGui.java
    jakarta/jmeter/trunk/xdocs/changes.xml
Comment 6 Philippe Mouawad 2011-09-12 10:00:53 UTC
*** Bug 51605 has been marked as a duplicate of this bug. ***