Bug 49923 - The latest thunk can't shutdown if add tomcat native java library dll
The latest thunk can't shutdown if add tomcat native java library dll
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Catalina
trunk
PC Windows Vista
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-09-14 02:34 UTC by heyoulin
Modified: 2010-10-04 05:22 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description heyoulin 2010-09-14 02:34:35 UTC
The latest thunk can't shutdown if add tomcat native java library dll
Comment 1 Mladen Turk 2010-10-04 03:29:58 UTC
Can we get some thread dump when the shutdown is in progress.
Seems like a bug in stop() caused by a worker thread been locked
and not notified about we are going to shutdown.
Comment 2 Mladen Turk 2010-10-04 05:22:29 UTC
Fixed in the trunk