Bug 49666 - CSV Header read as data after EOF
CSV Header read as data after EOF
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.4
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-07-29 06:22 UTC by André Versluis
Modified: 2013-01-08 17:29 UTC (History)
1 user (show)



Attachments
Proposal patch (4.63 KB, patch)
2010-07-30 04:47 UTC, Milamber
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description André Versluis 2010-07-29 06:22:11 UTC
When a CSV Data Set Config element is defined with the variable names field empty, the first line that is read is interpreted as fields containing the variable names.
When data lines are read from this file until EOF (Recycle on EOF?: set to "true"), the first line, containing the variable names is interpreted as data. In the case where the first line is the header, this line should be skipped, reading data should start again at the second line.
Comment 1 Milamber 2010-07-30 04:47:09 UTC
Created attachment 25820 [details]
Proposal patch
Comment 2 Sebb 2010-08-16 12:41:27 UTC
Looks good; go ahead and apply the patch.
Comment 3 Milamber 2010-08-16 15:02:35 UTC
Thanks for the report; fixed in SVN:

URL: http://svn.apache.org/viewvc?rev=986094&view=rev
Log:
Bug 49666 - CSV Header read as data after EOF

Modified:
    jakarta/jmeter/trunk/src/components/org/apache/jmeter/config/CSVDataSet.java
    jakarta/jmeter/trunk/src/core/org/apache/jmeter/services/FileServer.java
    jakarta/jmeter/trunk/test/src/org/apache/jmeter/config/TestCVSDataSet.java
    jakarta/jmeter/trunk/xdocs/changes.xml
Comment 4 Matteo Turra 2013-01-08 17:29:37 UTC
*** Bug 54389 has been marked as a duplicate of this bug. ***