Bug 4961 - JDBCStore problems with Oracle, others(?)
JDBCStore problems with Oracle, others(?)
Status: RESOLVED DUPLICATE of bug 7170
Product: Tomcat 4
Classification: Unclassified
Component: Catalina:Modules
4.0 Final
PC All
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2001-11-19 18:15 UTC by Axel Guerrero
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Guerrero 2001-11-19 18:15:25 UTC
Looking at the source code for JDBCStore.java, i found a query in public String
[] keys() that does not run under Oracle...
The query is "select count(s.id), s.id from session s, session c group by c.id."
Oracle throws an ORA-00979: not a GROUP BY expression
Comment 1 Radim Kubacki 2002-03-01 13:50:56 UTC
I would say it should be '... group by s.id'. 
Comment 2 Remy Maucherat 2002-04-23 11:07:26 UTC
Looking back at this bug, this looks like a duplicate of bug 7170.

*** This bug has been marked as a duplicate of 7170 ***