Bug 49484 - Remove custom IE6+ workaround from config file
Remove custom IE6+ workaround from config file
Status: RESOLVED FIXED
Product: Apache httpd-1.3
Classification: Unclassified
Component: core
HEAD
PC All
: P2 normal (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-06-21 21:24 UTC by Abu Obeida Bakhach
Modified: 2010-07-20 19:34 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abu Obeida Bakhach 2010-06-21 21:24:46 UTC
IE6+ used to have a problem that required these extra lines in the config file. They are not required anymore as Micorosoft has corrected the issue in a hotfix released a while back.

The fix:
http://support.microsoft.com/kb/921090

The unneeded config code:
#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
#   "force-response-1.0" for this.
BrowserMatch ".*MSIE.*" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0
 
#   Per-Server Logging:
Comment 1 Greg Stein 2010-07-20 19:34:48 UTC
Fixed in r966055 (which should appear in the next 2.3.x release). I'll propose it for a 2.2.x backport.