Bug 49187 - Crash mod_mem_cache and mod_svn
Crash mod_mem_cache and mod_svn
Status: NEW
Product: Apache httpd-2
Classification: Unclassified
Component: Core
2.2.14
PC Linux
: P2 normal (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-04-26 13:51 UTC by Chuck Short
Modified: 2010-04-26 13:51 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Short 2010-04-26 13:51:45 UTC
Hi,

This was originally reported in http://bugs.launchpad.net/bugs/568468. I have attached the information that the user has provided below. If you have any questions please let me know.

===================


Binary package hint: apache2

On a lucid server we see apache segmentation faulting at a high rate. This causes svn checkouts to fail depending on the client (e.g. on Ubunut 9.10 subversion with neon as dav lib is okay, serf is not). I was able to reproduce it with a minimal setup:

Using lucid from today, i.e. with

with mods-enabled:
alias auth_basic authz_default authz_host cache dav dav_svn deflate info mem_cache mime

dav_svn.conf:
<Location /svn>
  DAV svn
  SVNParentPath /var/lib/svn
  SVNListParentPath on
  SVNPathAuthz off
</Location>

mem_cache.conf is untouched. I created an svn repo /var/lib/svn/svn_memcache (see attachment). With some clients I cannot check it out, it fails for bad.root segfaulting apache. wget http://localhost/svn/svn_memcache/bad.root never succeeds.

If I disable mem_cache it works. (Yes, I know that we shouldn't have it enabled for serving svn to begin with and I am thankful for mem_cache pointing this out but that's not the point here :-)

Cheers, Axel.

================



Sure, here it is.

#0 0x00007ffff5cc613e in ?? () from /usr/lib/apache2/modules/mod_cache.so
#1 0x00007ffff589c1ed in ?? () from /usr/lib/apache2/modules/mod_dav_svn.so
#2 0x00007ffff5ab694a in ?? () from /usr/lib/apache2/modules/mod_dav.so
#3 0x00007ffff7fd6140 in ap_run_handler (r=0x7ffff834eeb8) at /build/buildd/apache2-2.2.14/server/config.c:159
#4 0x00007ffff7fd9aa8 in ap_invoke_handler (r=0x7ffff834eeb8) at /build/buildd/apache2-2.2.14/server/config.c:373
#5 0x00007ffff7fe7678 in ap_process_request (r=0x7ffff834eeb8) at /build/buildd/apache2-2.2.14/modules/http/http_request.c:282
#6 0x00007ffff7fe4528 in ap_process_http_connection (c=0x7ffff834af28) at /build/buildd/apache2-2.2.14/modules/http/http_core.c:190
#7 0x00007ffff7fddcf8 in ap_run_process_connection (c=0x7ffff834af28) at /build/buildd/apache2-2.2.14/server/connection.c:43
#8 0x00007ffff7fec037 in child_main (child_num_arg=<value optimized out>)
    at /build/buildd/apache2-2.2.14/server/mpm/prefork/prefork.c:662
#9 0x00007ffff7fec306 in make_child (s=0x7ffff8214938, slot=0) at /build/buildd/apache2-2.2.14/server/mpm/prefork/prefork.c:702
#10 0x00007ffff7fec953 in ap_mpm_run (_pconf=<value optimized out>, plog=<value optimized out>, s=<value optimized out>)
    at /build/buildd/apache2-2.2.14/server/mpm/prefork/prefork.c:978
#11 0x00007ffff7fc2350 in main (argc=2, argv=0x7fffffffe758) at /build/buildd/apache2-2.2.14/server/main.c:742

Looks like the modules don't have debug info - that's really unfortunate... Let me know if I can help with providing them somehow (i.e. whether I should build the modules from source).