Bug 48991 - Unnecessary artifact dependencies for 1.2.15 release.
Unnecessary artifact dependencies for 1.2.15 release.
Status: RESOLVED DUPLICATE of bug 43304
Product: Log4j
Classification: Unclassified
Component: Other
1.2
All All
: P2 normal
: ---
Assigned To: log4j-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-03-26 01:58 UTC by Arvind Prabhakar
Modified: 2010-03-26 05:39 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvind Prabhakar 2010-03-26 01:58:16 UTC
The pom packaged with 1.2.15 release of log4j published in the central maven repository has dependencies including the following:

- javax.mail:main
- javax.jms:jms
- com.sun.jdmk:jmxtools
- com.sun.jmx:jmxri

This forces projects that wish to upgrade to log4j 1.2.15 to either provide these dependencies or manually exclude them. Moreover, some of these dependencies are not available in central maven repository due to license restrictions.

Suggested Fix: 
-----------
Please mark these dependencies as optional so that consumers of log4j are not forced to include or manually exclude them.
Comment 1 Curt Arnold 2010-03-26 05:39:31 UTC
Previously reported in bugs 43304 and 48216.  Should be fixed in the current SVN HEAD which should become log4j 1.2.16 shortly.

*** This bug has been marked as a duplicate of bug 43304 ***