Bug 48774 - DNS Aliasing breaks tomcat session management
DNS Aliasing breaks tomcat session management
Status: RESOLVED DUPLICATE of bug 48379
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
unspecified
PC All
: P2 enhancement (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-02-19 05:32 UTC by James Roper
Modified: 2010-04-17 03:27 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Roper 2010-02-19 05:32:32 UTC
One of the big problems that comet applications encounter is the 2 connection limit of the HTTP specification, which some browsers (eg, IE6 and IE7) adhere strictly to.  The most common approach to getting around this is DNS aliasing, where a wildcard DNS record causing all requests for all subdomains of a host to go to that host.  However, there is no way to configure what domain the JSESSIONID gets set on, which is always set to the incoming host name.  This completely breaks Tomcat session management when DNS aliasing is being used.

If tomcat is to support comet (which it does), this seems like a pretty major hole in its support of it, considering most comet implementations use DNS aliasing.
Comment 1 Mark Thomas 2010-04-17 03:27:29 UTC

*** This bug has been marked as a duplicate of bug 48379 ***