Bug 48709 - TCP Sampler Config setting "classname" has no effect
TCP Sampler Config setting "classname" has no effect
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3.4
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-02-09 01:29 UTC by Andrey Pohilko
Modified: 2010-06-28 15:08 UTC (History)
0 users



Attachments
Screenshot of TCP Config (28.86 KB, image/png)
2010-02-09 01:33 UTC, Andrey Pohilko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Pohilko 2010-02-09 01:29:44 UTC

    
Comment 1 Andrey Pohilko 2010-02-09 01:32:46 UTC
Sorry, occasional Enter...

The issue is: when I define classname in Config, it does not applied in TCP Samplers. All other options works fine. I have to define classname in each sampler.

I expected that I define classname in Config and leave it empty in all TCP Samplers and all samplers use Config setting as Host or Port fields do.
Comment 2 Andrey Pohilko 2010-02-09 01:33:56 UTC
Created attachment 24950 [details]
Screenshot of TCP Config
Comment 3 Sebb 2010-06-28 15:08:25 UTC
Thanks for the report.

The classname is referenced in the threadStarted() method, which is called before the TCP config items are merged in. Other TCP config fields are referenced in the sample() method which is processed after the merge.

Fixed by doing the setup in the first sample call. 
A bit messy, but should work...

URL: http://svn.apache.org/viewvc?rev=958685&view=rev
Log:
Bug 48709 - TCP Sampler Config setting "classname" has no effect

Modified:
   jakarta/jmeter/trunk/src/protocol/tcp/org/apache/jmeter/protocol/tcp/sampler/TCPSampler.java
   jakarta/jmeter/trunk/xdocs/changes.xml