Bug 47870 - JMSSubscriber fails due to NPE
JMSSubscriber fails due to NPE
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3.4
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
http://www.ubik-ingenierie.com
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-09-18 07:48 UTC by Philippe Mouawad
Modified: 2009-09-24 09:22 UTC (History)
1 user (show)



Attachments
Corrects NPE (1.08 KB, patch)
2009-09-18 07:48 UTC, Philippe Mouawad
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2009-09-18 07:48:01 UTC
Created attachment 24292 [details]
Corrects NPE

Hello,
When you use JMSSubscriber you always get NPE exception at line 87 in trunk
head (198/09/2009)
Investigating a little it seems that _CONN and _SESSION where accessed  before
being initialized.

Attached is a patch that corrects the issue.
By the way close method should try/catch different close method to ensure no
leak.

Philippe
http://www.ubik-ingenierie.com
Comment 1 Sebb 2009-09-19 07:16:55 UTC
Thanks very much for the patch; applied to SVN:

URL: http://svn.apache.org/viewvc?rev=816929&view=rev
Log:
Bug 47870 - JMSSubscriber fails due to NPE
Comment 2 Sebb 2009-09-24 09:22:46 UTC
*** Bug 47899 has been marked as a duplicate of this bug. ***