Bug 47592 - Run Thread groups consecutively with "Stop test" on error, JMeter will not mark to finished
Run Thread groups consecutively with "Stop test" on error, JMeter will not ma...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
unspecified
PC All
: P2 regression (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-07-27 16:30 UTC by Milamber
Modified: 2009-11-20 12:15 UTC (History)
1 user (show)



Attachments
sample test plan (19.66 KB, application/octet-stream)
2009-07-27 16:30 UTC, Milamber
Details
Proposal patch (590 bytes, patch)
2009-07-27 16:40 UTC, Milamber
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Milamber 2009-07-27 16:30:49 UTC
Created attachment 24046 [details]
sample test plan

With this test plan, checkbox Run Tread groups consecutively active, and one thread group with "Stop test" on error, JMeter will not mark finished (right box is always green)

(since JMeter 2.3.3 with new stop / stop new behaviors)
Comment 1 Milamber 2009-07-27 16:40:18 UTC
Created attachment 24047 [details]
Proposal patch

test case : the sample test plan with and without checkbox "run tg consecutively" active
Comment 2 Sebb 2009-11-20 12:15:31 UTC
Thanks for the patch. Sorry for the long delay in applying it:

URL: http://svn.apache.org/viewvc?rev=882701&view=rev
Log:
Bug 47592 - Run Thread groups consecutively with "Stop test" on error, JMeter will not mark to finished