Bug 46562 - Reader not closed
Reader not closed
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Servlets:SSI
5.5.27
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-01-19 08:17 UTC by Michael Rauner
Modified: 2009-06-04 07:44 UTC (History)
0 users



Attachments
Test application (1.35 KB, application/octet-stream)
2009-01-28 06:52 UTC, Flavio Crispim
Details
Process Monitor logs. (3.38 KB, application/vnd.ms-excel)
2009-01-28 06:54 UTC, Flavio Crispim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Rauner 2009-01-19 08:17:14 UTC
SHTML files are locked when using windows. Closing the reader solves the problem.
Comment 1 Flavio Crispim 2009-01-20 13:07:12 UTC
(In reply to comment #0)
> SHTML files are locked when using windows. Closing the reader solves the
> problem.
> 

How to reproduce? Please, provide an example.
Comment 2 Michael Rauner 2009-01-20 23:33:23 UTC
Try editing an SSI Include with Dreamweaver on XP (version seems to be irrelevant). Eclipse and good editors will work.

Kind regards, Michael
Comment 3 Arunkumar 2009-01-22 08:17:40 UTC
Please Give Some more details about this bug , (explain briefly)
Comment 4 Michael Rauner 2009-01-22 09:00:03 UTC
If you try to edit a file which is served by the SSI servlet with Dreamweaver, you won't be able to save the file.

As a workaround I have added bufferedReader.close() at the end of processSSI(...) method call and things work fine.

Hope this helps, kind regards. Michael
Comment 5 Flavio Crispim 2009-01-28 06:52:56 UTC
Created attachment 23187 [details]
Test application

Test application, needs a SSI enabled TC.
Comment 6 Flavio Crispim 2009-01-28 06:54:29 UTC
Created attachment 23188 [details]
Process Monitor logs.
Comment 7 Flavio Crispim 2009-01-28 07:06:14 UTC
Hi

I don´t have permision to install Dreamweaver and I was unable reproduce this issue.

I´ve attached Process Monitor logs(http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx) and seems ok to me (here in my enviroment)

Enviroment
XP.sp3
SUN 1.6.0_11
TC 5.5.27

Let me know if you can reproduce with the Test-app (attached).

Flavio
Comment 8 Mark Thomas 2009-04-09 04:09:47 UTC
Thanks for the suggested fix. It has been applied to trunk and proposed for 6.0.x and 5.5.x
Comment 9 Mark Thomas 2009-04-28 06:27:03 UTC
This has been fixed in 6.0.x and will be in 6.0.20 onwards.
Comment 10 Mark Thomas 2009-06-04 07:44:07 UTC
This has been fixed in 5.5.x and will be included in 5.5.28 onwards.