Bug 46232 - Can't override XML parser implementation using endorsed mechanism
Can't override XML parser implementation using endorsed mechanism
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
6.0.18
Sun Solaris
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
: 46347 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-11-18 11:43 UTC by Russ Tokuyama
Modified: 2008-12-31 05:49 UTC (History)
1 user (show)



Attachments
Patch to setclasspath.sh to not set JAVA_ENDORSED_DIRS if already defined (433 bytes, patch)
2008-11-18 11:43 UTC, Russ Tokuyama
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Tokuyama 2008-11-18 11:43:27 UTC
Created attachment 22887 [details]
Patch to setclasspath.sh to not set JAVA_ENDORSED_DIRS if already defined

I can't override the XML parser implementation by setting the java.endorsed.dirs system property when using start.sh which calls catalina.sh. catalina.sh calls setclasspath.sh which sets this system property to point to "$BASEDIR"/endorsed via the JAVA_ENDORSED_DIRS environment variable and BASEDIR is set to CATALINA_HOME in catalina.sh.

I was able to override the XML parser implementation by modifying setclasspath.sh to not set JAVA_ENDORSED_DIRS if it is already defined.
Comment 1 Mark Thomas 2008-12-05 05:37:11 UTC
*** Bug 46347 has been marked as a duplicate of this bug. ***
Comment 2 Mark Thomas 2008-12-05 06:42:35 UTC
This has been fixed in trunk and proposed for 6.0.x.
I modified the proposed patch to cover the .bat file and to use the same method as elsewhere in the .sh scripts to test for an environment variable.
Comment 3 Mark Thomas 2008-12-31 05:49:51 UTC
This has been fixed in 6.0.x and will be included in 6.0.19 onwards.