Bug 45769 - Enhance docs IIS7/Win 2008 does not log URL properly
Enhance docs IIS7/Win 2008 does not log URL properly
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Documentation
unspecified
PC All
: P5 trivial (vote)
: default
Assigned To: Tomcat Developers Mailing List
http://tomcat.apache.org/connectors-doc/
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-09-08 17:14 UTC by zdenek
Modified: 2008-09-10 09:13 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zdenek 2008-09-08 17:14:46 UTC
This is an enhancement to documentation, which I have not found anywhere on the Internet.


When processing through isapi_redirect.dll, when installed with IIS7/Windows 2008 will not log original request and original query (cs-uri-stem cs-uri-query fields) properly. The problem IS NOT IN CONNECTOR, the issue apparently has been identified by Microsoft whereas SF_NOTIFY_LOG handler is not implemented correctly on IIS7 and will fail to log changes.

From what I gathered, the issue was reported to Microsoft few months back as qfe and there is an unpublished KB article 956120 with an unpublished hotfix.

I was pointed towards talking to Microsoft support to get the hotfix before it is released to public at large.
Comment 1 zdenek 2008-09-10 07:55:31 UTC
After I spoke with Microsoft, they made the Hotfix available for download via http://support.microsoft.com/kb/956120
Comment 2 Mark Thomas 2008-09-10 09:13:12 UTC
Thanks for the info. I have updated the connector docs (it will be in the next release) and in the meantime, this bug report is searchable.