Bug 45375 - Building log4j core without manually installing libraries in Maven
Building log4j core without manually installing libraries in Maven
Status: RESOLVED DUPLICATE of bug 44517
Product: Log4j
Classification: Unclassified
Component: Other
1.2
PC All
: P2 enhancement
: ---
Assigned To: log4j-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-07-10 11:46 UTC by Thorbjørn Ravn Andersen
Modified: 2009-01-14 11:24 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorbjørn Ravn Andersen 2008-07-10 11:46:20 UTC
When trying to build the 1.2.15 source from subversion the JMX libraries must be downloaded and installed manually.

According to http://forum.java.sun.com/thread.jspa?messageID=10223656 the core libraries are in Java 5 and the tools library should be downloadable from http://opendmk.dev.java.net.  

Hence I suggest putting the build requirement for log4j to a Java 5+ JVM (but still compile to the appropriate level for backwards compatability) and investigate if the rest could be downloaded automatically by maven.
Comment 1 Curt Arnold 2009-01-14 11:24:08 UTC

*** This bug has been marked as a duplicate of bug 44517 ***