Bug 45299 - javadoc page for jdbcappender
javadoc page for jdbcappender
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Appender
1.2
PC Windows 2000
: P2 trivial
: ---
Assigned To: log4j-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-06-27 07:39 UTC by j
Modified: 2008-08-12 10:04 UTC (History)
0 users



Attachments
move description up above red warning (929 bytes, patch)
2008-08-03 03:43 UTC, Thorbjørn Ravn Andersen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description j 2008-06-27 07:39:23 UTC
the javadoc index page that lists all methods starts having red text at JDBC appender and all text thereafter in red. This is caused by the warning message in the javadoc comments being 2 sentences long and highlighted in red. For the index page, javadoc program takes only the first sentence and so misses the closing font tag at the end of the second sentence. I use version 1.2.15.
Comment 1 Thorbjørn Ravn Andersen 2008-08-03 03:41:33 UTC
The URL for this is

http://logging.apache.org/log4j/1.2/apidocs/index-all.html#_J_

The problem is that JavaDoc uses the first sentence only, and the warning message is TWO sentences so the trailing </font> is not copied in.

By moving the actual description up above the warning message this should present an accurate overview in the index.
Comment 2 Thorbjørn Ravn Andersen 2008-08-03 03:43:03 UTC
Created attachment 22350 [details]
move description up above red warning
Comment 3 Curt Arnold 2008-08-05 21:50:29 UTC
Committed rev 683106.