Bug 44852 - SOAP/XML-RPC Request does not show Request details in View Results Tree
SOAP/XML-RPC Request does not show Request details in View Results Tree
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.3.1
PC Windows Vista
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-04-22 03:02 UTC by Jeroen Borgers
Modified: 2008-05-02 06:53 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Borgers 2008-04-22 03:02:25 UTC
We execute SOAP/XML-RPC Requests with SOAPAction disabled and XML content as Data.

We put variables in the request and would like to debug and see the actual values substituted. When looking in the View Results Tree, we see Sampler Result details in the tab, complete Response Data in thetab. Only in the Request tab, we see only the URL, '[no cookies]' and 'Request Headers:'. We would like to see the complete XML request content.
Comment 1 Sebb 2008-04-22 06:38:16 UTC

*** This bug has been marked as a duplicate of bug 44011 ***
Comment 2 Jeroen Borgers 2008-04-23 01:22:58 UTC
Bug 44011 does not say anything about the XML request.

Latest comment on 44011: 
The change in 2.3.1 has caused quite a few problems, so the next release of
JMeter will revert to the previous behaviour.

Will this previous behaviour show the XML request correctly?
Comment 3 Sebb 2008-04-23 01:34:25 UTC
Sorry, misread request as response. This is a different issue.

The Samplers generally don't show the full request, as that is known.

Changing to enhancement.
Comment 4 Jeroen Borgers 2008-04-23 01:40:48 UTC
Normal HTTPRequests do show the request content. Very useful for debugging and see the substituted values of variables. 

So this is not common to all samplers?
Comment 5 Jeroen Borgers 2008-04-23 01:43:32 UTC
JDBCRequest also shows the request (the actual query executed).
Comment 6 Jeroen Borgers 2008-04-28 01:22:41 UTC
As the samplers we use generally *do* show the request, my customer experiences this not as an enhancement request, but as a bug. Changed to severity major.
Comment 7 Sebb 2008-05-02 06:47:39 UTC
Fixed in SVN:

URL: http://svn.apache.org/viewvc?rev=652103&view=rev
Log:
Bug 44852 SOAP/ XML-RPC Request does not show Request details in View Results Tree
Comment 8 Jeroen Borgers 2008-05-02 06:53:07 UTC
Great! That is a quick fix. We will try it out.
Thanks.