Bug 44650 - CSV Data Set Config is ignoring quoted values
CSV Data Set Config is ignoring quoted values
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3
PC Windows XP
: P3 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-03-20 15:04 UTC by Tim Cham
Modified: 2008-03-22 15:17 UTC (History)
0 users



Attachments
Zip containing the JMeter test and csv files. (1.02 KB, application/octet-stream)
2008-03-20 15:04 UTC, Tim Cham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Cham 2008-03-20 15:04:40 UTC
Created attachment 21696 [details]
Zip containing the JMeter test and csv files.

Steps to reproduce the problem:
1. Add the BeanShell jar to you JMeter lib.
2. Run the attached JMeter test plan
3. Look at the console to see the output from the BeanShell script.

Expected Result:
column1: One
column2: Two, Three and Four

Actual Result
column1: One
column2: "Two

Seems like the CSV Data Config is ignoring the quotes.
Comment 1 Sebb 2008-03-21 12:34:30 UTC
CSV Dataset config does not currently handle quoted parameters.

This is not a bug, because it was never documented as doing so.

However, code has recently been added to SVN to handle quotes in CSV result files. Should be easy enough to use this in the CSV Dataset config element as well.
Comment 2 Sebb 2008-03-22 11:39:52 UTC
In the meantime, a work-round is to use a delimiter that does not appear in any values.
Comment 3 Sebb 2008-03-22 15:17:43 UTC
Fixed in SVN r640095.