Bug 43542 - MalformedURIException during usage of user FOP configuration...
MalformedURIException during usage of user FOP configuration...
Status: CLOSED FIXED
Product: Fop - Now in Jira
Classification: Unclassified
Component: fonts
0.94
Other Linux
: P2 normal
: ---
Assigned To: fop-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-10-03 07:18 UTC by Jiri Tyr
Modified: 2012-04-01 07:03 UTC (History)
0 users



Attachments
myfop2.xconf (9.98 KB, text/plain)
2007-10-03 07:20 UTC, Jiri Tyr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Tyr 2007-10-03 07:18:26 UTC
I just installed fop-0.94 with jeuclid-fop plug-in to I can test MathML support
in PDF. It works well until I use my configuration file (which worked like a
charm with fop-0.93). When I content out the content of <fonts>...</fonts> then
it works. If I uncomment even one <font></font> configuration FOP crash with
this error:

$ /usr/bin/fop -d -c /etc/xml/fop_settings/fop-0.94/conf/myfop2.xconf -fo
./docbook.fo -pdf ./docbook.pdf
Oct 3, 2007 3:57:19 PM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-height set to: 297mm
Oct 3, 2007 3:57:19 PM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-width set to: 210mm
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/xml/utils/URI$MalformedURIException
        at org.apache.fop.fonts.FontCache.addFont(FontCache.java:246)
        at
org.apache.fop.render.PrintRendererConfigurator.getFontInfoFromConfiguration(PrintRendererConfigurator.java:313)
        at
org.apache.fop.render.PrintRendererConfigurator.buildFontListFromConfiguration(PrintRendererConfigurator.java:196)
        at
org.apache.fop.render.PrintRendererConfigurator.configure(PrintRendererConfigurator.java:93)
        at
org.apache.fop.render.pdf.PDFRendererConfigurator.configure(PDFRendererConfigurator.java:70)
        at
org.apache.fop.render.RendererFactory.createRenderer(RendererFactory.java:187)
        at org.apache.fop.area.RenderPagesModel.<init>(RenderPagesModel.java:71)
        at org.apache.fop.area.AreaTreeHandler.setupModel(AreaTreeHandler.java:126)
        at org.apache.fop.area.AreaTreeHandler.<init>(AreaTreeHandler.java:101)
        at
org.apache.fop.render.RendererFactory.createFOEventHandler(RendererFactory.java:224)
        at org.apache.fop.fo.FOTreeBuilder.<init>(FOTreeBuilder.java:100)
        at org.apache.fop.apps.Fop.createDefaultHandler(Fop.java:147)
        at org.apache.fop.apps.Fop.<init>(Fop.java:82)
        at org.apache.fop.apps.FopFactory.newFop(FopFactory.java:249)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:94)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:197)

Is there some major change in FOP configuration file which could produce the
above error? I tried modify config file described at
http://xmlgraphics.apache.org/fop/0.94/configuration.html and
http://xmlgraphics.apache.org/fop/0.94/fonts.html but with any result. Do you
know what could be wrong?
Comment 1 Jiri Tyr 2007-10-03 07:20:58 UTC
Created attachment 20910 [details]
myfop2.xconf

My FOP configuration file.
Comment 2 Jeremias Maerki 2007-10-03 07:33:17 UTC
Looks like an oversight when font auto-detection was added. The CachedFontInfo
class references classes (URI) from Xalan-J. Normally, our dependency would only
be on JAXP and not any JAXP implementation directly. We'll have to fix that.

In the meantime, you can simply make sure you've got xalan.jar in your classpath
so FOP has access to the URI class.
Comment 3 Jiri Tyr 2007-10-03 07:50:28 UTC
(In reply to comment #2)
> We'll have to fix that.
Please let me know when you fix it in trunk version. I will test it.

> In the meantime, you can simply make sure you've got xalan.jar in your classpath
> so FOP has access to the URI class.

I can confirm that with xalan.jar in CP it works well. Thank you for temporary
workaround.
Comment 4 Jeremias Maerki 2007-10-04 02:06:30 UTC
Problem fixed in FOP Trunk:
http://svn.apache.org/viewvc?rev=581806&view=rev
Comment 5 Glenn Adams 2012-04-01 07:03:16 UTC
batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed