Bug 4352 - JDBCRealm does not work with CLIENT-CERT auth-method
JDBCRealm does not work with CLIENT-CERT auth-method
Status: RESOLVED DUPLICATE of bug 19767
Product: Tomcat 4
Classification: Unclassified
Component: Catalina
4.0.1 Final
All other
: P3 normal with 2 votes (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2001-10-22 15:07 UTC by kar yeow
Modified: 2004-11-16 19:05 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kar yeow 2001-10-22 15:07:58 UTC
When log in using CLIENT-CERT and MemoryRealm, the certificate's subject is 
used to match the user name to log the user in.  But when using the JDBCRealm , 
it fails, because the getPrincipal() method always return null!!!.
Comment 1 Craig McClanahan 2001-10-29 12:36:12 UTC
Assign to myself for investigation.
Comment 2 Mark Thomas 2004-09-12 22:08:25 UTC
The issue here is a subset of the issues in the duplicate.

*** This bug has been marked as a duplicate of 19767 ***