Bug 43482 - AuthLDAPURL must contain a final path of branch?(ldap_search_ext_s)
AuthLDAPURL must contain a final path of branch?(ldap_search_ext_s)
Status: RESOLVED DUPLICATE of bug 43481
Product: Apache httpd-2
Classification: Unclassified
Component: mod_authn_ldap
2.2.3
PC Linux
: P2 critical (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
: ErrorMessage
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-09-26 05:11 UTC by Ayed
Modified: 2007-09-26 06:04 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ayed 2007-09-26 05:11:35 UTC
the configuration with the module authnz_ldap worked very well.
with this line:(apache look for authentification in full AD
"ldap://10.x.y.z:389/DC=Domain?sAMAccountName?sub?(objectClass=user
 since yesterday a fatal error appeared: Internal Server Error
when I look at apache2'log file I find:



*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
[warn] [client 127.0.0.1][7709] auth_ldap authentificate: user salah
authentificate failed; URI /SimpleRepos [ldap_search_ext_s() for user
failed][Operation error]




I try to change configuration and make it more precised:
AuthLDAPURL
"ldap://10.x.y.z:389/OU=Users,OU=XYZ,DC=Domain?sAMAccountName?sub?(objectClass=user
)"

Now it work but only for users in "OU=Users,OU=XYZ,DC=Domain"
Comment 1 Ruediger Pluem 2007-09-26 06:04:54 UTC

*** This bug has been marked as a duplicate of 43481 ***