Bug 43389 - Allow Include files to be found relative to the current JMX file
Allow Include files to be found relative to the current JMX file
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
PC Linux
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-09-13 12:14 UTC by Frank Schneider
Modified: 2010-05-21 15:37 UTC (History)
2 users (show)



Attachments
Patch to allow loading files relative to the main jmx file (2.30 KB, text/plain)
2010-05-20 12:20 UTC, Luciana Moreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Schneider 2007-09-13 12:14:28 UTC
Tested with nightly build: r574051

The include controller runs well but only with a absolute path to the file.
With a relative path I get the Error message: No such file or directory
But with jmeter 2.2 it works well.
Comment 1 Frank Schneider 2007-09-13 12:55:42 UTC
Not a bug. My fault. Start JMeter from Start menue in GNOME so
the relative path is not from the bin directory.
Comment 2 Luciana Moreira 2010-05-13 03:50:31 UTC
I am working with version 2.3.4 and I have the same issue. I am using the same JMeter scripts in different machines with different paths to the $JMETER_HOME$/bin directory and also different paths to the scripts.

Nevertheless, all scripts are in the same relative path in all machines. So ideally JMeter would make the paths relative to the loaded jmx file so i would not get the Error message: No such file or directory.

I saw someone suggesting to simply go to the desired working directory and start the jmeter gui from there. If I am working on different scripts I have to start JMeter every time I change the script.
Comment 3 Luciana Moreira 2010-05-20 12:20:59 UTC
Created attachment 25466 [details]
Patch to allow loading files relative to the main jmx file
Comment 4 Sebb 2010-05-21 15:37:19 UTC
Thanks, patch applied:

URL: http://svn.apache.org/viewvc?rev=947135&view=rev
Log:
Bug 43389 - Allow Include files to be found relative to the current JMX file

Modified:
   jakarta/jmeter/trunk/src/components/org/apache/jmeter/control/IncludeController.java
   jakarta/jmeter/trunk/xdocs/changes.xml
   jakarta/jmeter/trunk/xdocs/usermanual/component_reference.xml