Bug 43332 - 2.3RC4 does not clear Guis based on TestBean
2.3RC4 does not clear Guis based on TestBean
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
unspecified
Other other
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-09-08 07:19 UTC by Sebb
Modified: 2007-09-19 09:41 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2007-09-08 07:19:24 UTC
Create a JDBC sampler, enter some data
Create a second JDBC sampler - the data is copied from the old sampler.

This is new to 2.3RC4 - it worked in 2.2 and 2.3RC3.

However, this was probably because of bug 43122 which was fixed in 2.3RC3.

It looks like the problem is that the clearGui() method is not implemented for 
TestBeanGUI.

I'm working on it - this is just to record the problem so it is not lost.
Comment 1 Sebb 2007-09-08 07:26:13 UTC
See also bug 43292 which relates to the Java Request Gui (though that has 
always been a bug)
Comment 2 Sebb 2007-09-08 08:36:40 UTC
Fixes applied in r573859 and r573857.

Leave open for now in case further problems found.
Comment 3 Sebb 2007-09-19 09:41:10 UTC
Seems fine