Bug 43313 - log4j 1.2.16 release considerations and discussion
log4j 1.2.16 release considerations and discussion
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Other
1.2
Other other
: P2 normal
: ---
Assigned To: log4j-dev
:
: 45527 (view as bug list)
Depends on: 44386 43325 45029 46404
Blocks:
  Show dependency tree
 
Reported: 2007-09-05 10:22 UTC by Curt Arnold
Modified: 2012-05-26 13:00 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Curt Arnold 2007-09-05 10:22:15 UTC
Probably should be released at the same time chainsaw is ready to go.
Comment 1 Paul Smith 2007-09-05 15:12:21 UTC
Could we release the Receivers sub-projects and zeroconf before hand though?
Comment 2 Curt Arnold 2007-09-05 15:29:40 UTC
The natural time for 1.2.16 in my opinion (barring any emerging critical issue) would be simulatenous with 
the initial release of Chainsaw 2 based on log4j 1.2.x which would imply at the same time or after 
receivers or zeroconf are released.
Comment 3 Thorbjørn Ravn Andersen 2008-07-02 17:18:40 UTC
Seeing nine months later that 1.2.16 has not been released, it might be appropriate to have a short list what needs to be done where?

Am I correct in assuming that it is primarily ChainSaw issues that are pending?  
Comment 4 Paul Smith 2008-07-02 18:29:32 UTC
I don't think anything is preventing log4j 1.2.16 from being finalized.  I can't think of what else was planned to go.  I wouldn't mind having 1.2.16 out in the wild as it is, because then some of the sub-projects can also be voted on for release.

Perhaps Curt can comment on what else he might have had in mind to do?
Comment 5 Scott Deboy 2008-07-02 19:48:14 UTC
Not that it's terribly related to this bug (other than the 1st comment was re: chainsaw being ready), but I have an in-progress Chainsaw change to add hide/show of drag & drop tab as a preference...it gets in the way if you don't use xml layout.

If this doesn't go, that's ok...the prefs logic is a bit to work through but it's close..
Comment 6 Thorbjørn Ravn Andersen 2008-08-02 13:46:28 UTC
I am looking through the current log4j issues so we can put those aside which is not holding up this release.  Feel free to help.

I have created bug 45527 as an "umbrella-issue" and set this issue to block it (meaning that we should agree first :) )

If there is work needing to be done, that is not covered by an issue, please create issues for them as it helps others to see what is going on.

One such would be to get the official build process to be simply "extract from SVN, run "maven foo:bar" and deploy the resulting libraries.
Comment 7 Curt Arnold 2008-08-12 10:04:59 UTC
*** Bug 45527 has been marked as a duplicate of this bug. ***
Comment 8 grobmeier 2012-05-26 13:00:07 UTC
1.2.16 is out