Bug 43168 - Exception when running multiple tests in same remote engine
Exception when running multiple tests in same remote engine
Status: RESOLVED DUPLICATE of bug 50659
Product: JMeter
Classification: Unclassified
Component: Main
2.3
Other other
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on: 51938
Blocks:
  Show dependency tree
 
Reported: 2007-08-20 06:58 UTC by Sebb
Modified: 2012-05-28 13:56 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2007-08-20 06:58:46 UTC
If a client tries to start two tests in the same remote engine, then failures 
may result.

This is not really a bug, as it probably does not make sense to run multiple 
tests in the same engine. But worth recording in case it can be fixed easily - 
either by allowing multiple concurrent tests, or by preventing them.

Sample error from Branch 2.2 (r567702)

2007/08/20 14:41:56 ERROR - jmeter.engine.StandardJMeterEngine: Error occurred 
compiling the tree: java.util.ConcurrentModificationException
	at java.util.LinkedHashMap$LinkedHashIterator.nextEntry
(LinkedHashMap.java:358)
	at java.util.LinkedHashMap$ValueIterator.next(LinkedHashMap.java:373)
	at org.apache.jmeter.testelement.property.PropertyIteratorImpl.next
(PropertyIteratorImpl.java:50)
	at org.apache.jmeter.engine.util.ValueReplacer.replaceValues
(ValueReplacer.java:113)
	at org.apache.jmeter.engine.util.ValueReplacer.replaceValues
(ValueReplacer.java:65)
	at org.apache.jmeter.engine.PreCompiler.addNode(PreCompiler.java:58)
	at org.apache.jorphan.collections.HashTree.traverse(HashTree.java:956)
	at org.apache.jmeter.engine.StandardJMeterEngine.compileTree
(StandardJMeterEngine.java:174)
	at org.apache.jmeter.engine.StandardJMeterEngine.run
(StandardJMeterEngine.java:316)
	at java.lang.Thread.run(Thread.java:534)

Meanwhile, this is documented as a known restriction.
Comment 1 Philippe Mouawad 2012-05-28 13:55:43 UTC
Fixed in rev 1066684 in release 2.5

*** This bug has been marked as a duplicate of bug 50659 ***
Comment 2 Philippe Mouawad 2012-05-28 13:56:28 UTC
Fixed by preventing client from starting a new test while a test is running.