Bug 43122 - GUI changes not always picked up when short-cut keys used (2.3RC3)
GUI changes not always picked up when short-cut keys used (2.3RC3)
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3
Other Linux
: P3 minor (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-08-14 08:49 UTC by Ivan Rancati
Modified: 2007-09-03 03:37 UTC (History)
0 users



Attachments
Suggested patch (800 bytes, patch)
2007-08-29 11:57 UTC, Alf Hogemark
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Rancati 2007-08-14 08:49:57 UTC
problem as reproed by me:

If I open with 2.3RC3 a test plan that was saved with the "Log errors only"
option, then disable the option and run the tests,  I still don't see
successful results in View Results Tree. 

this is on linux (Kubuntu) with Sun jdk 1.5.0_10
============================================================
comment from Sebb with a workaround:

Just tried it, and yes, I can see the same.

It seems that the change of setting does not take properly.
Selecting a different element and coming back may fix it.
Comment 1 Sebb 2007-08-14 13:37:27 UTC
It's a bit odd - changes seem to depend on whether you run the JMX first.

Load a JMX with "errors only" selected, deselect it, run the plan: this works 
OK.

However, load JMX, run it, then change the setting - and the next run does not 
pick up the change. 

Changing the selected GUI element seems to reset whatever problem the run 
command causes.

This bug is probably related to the major change introduced to fix the clear() 
method ambiguities, but it's not yet obvious what the fault is.
Comment 2 Sebb 2007-08-28 09:00:30 UTC
In fact the bug is due to the change in GuiPackage.java introduced to fix bug 
30210 and bug 39427 - it is not related to the clear() changes.
Comment 3 Sebb 2007-08-28 09:05:03 UTC
(In reply to comment #2)
> In fact the bug is due to the change in GuiPackage.java introduced to fix 
bug 
> 30210 

That should be bug 30120

> and bug 39427 - it is not related to the clear() changes.

Comment 4 Alf Hogemark 2007-08-29 11:54:22 UTC
(In reply to comment #3)

This is a general problem that can be reproduced as follows :
Open a test plan, select any node in the tree.
Run the test.
Now any changes made to the node that was selected when you ran the test will be
lost when you select another node in the test plan.
In fact, if you perform any action, for example Edit->Help, you will see the
same behavior.

Comment 5 Alf Hogemark 2007-08-29 11:57:57 UTC
Created attachment 20731 [details]
Suggested patch

This changes the ActionRouter, so that it call GuiPackage.updateCurrentGui
instead of updateCurrentNode. If "updateCurrentNode" is called, then the
"currentNodeUpdated" will "true" afterwards, which means any changes made to
the node will not be moved from GUI to model.
Calling "updateCurrentGui" will leave "currentNodeUpdated" at "false"
afterwards, and therefore any changes made in the GUI will correctly be copied
into the model.
Comment 6 Sebb 2007-08-30 14:20:05 UTC
Thanks - that seems to have fixed it. Bugs 30120 and 39427 still remain fixed.