Bug 42948 - Problems with Proxy gui table fields in Java 1.6
Problems with Proxy gui table fields in Java 1.6
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.2
PC Windows XP
: P3 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-07-20 16:03 UTC by John Maline
Modified: 2007-09-09 11:41 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Maline 2007-07-20 16:03:48 UTC
I'm unable to edit existing entries in the URL Pattern include/exclude lists. 
Specifically, I can't get to a "normal" editing mode in the JTable component
(flashing vertical bar cursor) to sensibly edit an existing entry.

I can do the inital entry.  I can sort of get focus to an entry where I can
append to an existing entry or use the backspace key to delete from the end. But
I can't edit in the middle of an existing entry.

Steps to reproduce:
1. Open JMeter
2. Right-click WorkBench, Add, Non-Test Elements, HTTP Proxy Server
3. Under URL Patterns to Include, click Add
4. Click the JTable cell, type "abc"
5. Click another component (e.g., Port)
6. Click that same cell in the Include list between the "b" and the "c".
7. Note lack of blinking cursor
8. Type "zzz".
9. Note that the insertion happened at the end, not between "b" and "c".
10.Use the left-arrow key to try to move the cursor earlier in the "abczzz" string.
11.Type "yyy".
12.Note that the insertion happened at the end, despite your left-arrow attempts.

This bug appears to also exist in 2.3RC3.

This bug appears to not exist running on Mac OS 10.4.  I can get a blinking
vertical-bar cursor there.
Comment 1 John Maline 2007-07-20 16:06:04 UTC
I've recreated this bug running JMeter with Sun Java 1.5.0_recent and 1.6.0_02
Comment 2 Alf Hogemark 2007-07-28 03:57:37 UTC
I think this might be related to Jtable and edit focus.
I might look further into it.

For now, the workaround is to double click in the table cell, so that you are
sure that the cell is in proper edit focus. Then you will also see the caret,
i.e. "flashing vertical bar cursor" that you are looking for.
Comment 3 John Maline 2007-08-15 13:36:39 UTC
My experience is that this doesn't work on the Windows platforms (Windows XP SP2
+ Java 1.5.0_various).  I click, double-click and every other count of clicks. 
I never get a flashing vertical bar cursor, nor the ability to edit aside from
appending to or deleting from the end.

I've tried on Mac OS X 10.4 and I can get proper focus and blinking cursor.
Comment 4 Sebb 2007-09-01 04:25:19 UTC
Works for me on WinXP2/Java 1.5.0_12, but one has to triple-click.

Also, if you can get to the end, you should be able to use the left cursor key 
to move within the field.

Can you try these and report back?
Comment 5 John Maline 2007-09-04 12:48:42 UTC
I did manage to get normal focus (blinking vertical cursor that I can move,
ability to do arbitrary edits) if I clicked madly enough with 1.5.0_12. 
Previously I didn't think I was able to get there on Windows.

Same good luck on 1.4.2_15.

I had bad luck with 1.6.0_02.  That one still seems to resist any attempt to get
normal focus in the include/exclude fields.

This is all Windows XP SP2.

In my initial attempts, I maybe didn't click madly enough.  I think there's
still something wrong.  Maybe bad interaction with the listeners installed in
this panel.  But it's not quite as bad as I initially thought.
Comment 6 Sebb 2007-09-04 13:24:55 UTC
I can confirm the problem with Java 1.6.0_02 - this obviously needs further 
work to establish the cause of the problem.

Even cursor keys, and Home End seem to cause the focus to be lost.
Comment 7 Sebb 2007-09-09 11:41:12 UTC
See also bug 41905, which is basically the same.

Checked in a fix to SVN as r574048.