Bug 42611 - ERFATestCase fails on some JDK's
ERFATestCase fails on some JDK's
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Appender
1.2
Other other
: P2 normal
: ---
Assigned To: log4j-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-06-06 19:52 UTC by Curt Arnold
Modified: 2007-06-06 19:55 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Curt Arnold 2007-06-06 19:52:23 UTC
ERFATestCase (test of org.apache.log4j.varia.ExternallyRolledFileAppender) fails on some JVM's (Sun Linux 
JVM's in particular).  The apparently cause of the problem is attempting to trigger a roll on the main test 
thread before the socket has been set up on another thread.  Adding a sleep to allow the appender to 
complete initialization before testing suppressed the problem.
Comment 1 Curt Arnold 2007-06-06 19:55:04 UTC
Committed rev 545028