Bug 41791 - Tomcat behaves inconsistently concerning flush-packets
Tomcat behaves inconsistently concerning flush-packets
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Connectors
6.0.10
All All
: P2 enhancement (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-03-07 19:24 UTC by Sven
Modified: 2010-09-29 05:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven 2007-03-07 19:24:06 UTC
If the APR library is installed and working, Tomcat will send ajp flush-packets.
If the APR library is not install or not working, Tomcat will not send ajp
flush-packets.

The cause is, that Tomcat choses either org.apache.coyote.ajp.AjpAprProtocol or
org.apache.jk.server.JkCoyoteHandler as the backend for the AJP connector
depending on whether APR is usable.

AjpAprProtocol sends flush-packets, JkCoyoteHandler does not.

There seems to be org.apache.coyote.ajp.AjpProtocol, which supports
flush-packets too. This might be work in progress.


Please either stabalize org.apache.coyote.ajp.AjpProtocol or extend JkCoyoteHandler.


Last Version tested: Tomcat 6.0.10
Comment 1 Tim Whittington 2010-09-29 05:07:46 UTC
The AJP connectors in trunk (7.0.x) both do flushes now.