Bug 40954 - Statistical mode in distributed testing shows wrong results
Statistical mode in distributed testing shows wrong results
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.2.1
All All
: P2 major (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-11-13 01:27 UTC by Rub
Modified: 2006-11-27 14:39 UTC (History)
0 users



Attachments
Patch to fix startTime's bug (785 bytes, patch)
2006-11-13 01:29 UTC, Rub
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rub 2006-11-13 01:27:25 UTC
All StatisticalSampleResult object have a startTime of 0 so the all the elapsed
times of the samples are in the order of years! The problem is easily fixed
adding a few lines in Statistical.add(SampleResult res). Just a check to see if
startTime is zero and if so set the startTime to the startTime of the incoming
SampleResult.
Comment 1 Rub 2006-11-13 01:29:40 UTC
Created attachment 19117 [details]
Patch to fix startTime's bug

startTime is always zero. THis patch takes the first non-zero startTime in
incoming SampleResults as the startTime for the whole SampleStatisticalResult.
Comment 2 Sebb 2006-11-27 14:39:05 UTC
Thanks - fix added to SVN in rel-2-2 branch. This will appear in the next
"nightly" build (and the next release)