Bug 40773 - XML JTL not parsed correctly
XML JTL not parsed correctly
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.2
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-10-17 00:01 UTC by Rub
Modified: 2006-10-20 16:35 UTC (History)
0 users



Attachments
svn patch file for files SampleResult.java and SampleResultConverter.java (1.95 KB, patch)
2006-10-17 03:03 UTC, Rub
Details | Diff
svn patch file for files SampleResult.java and SampleResultConverter.java (2.10 KB, patch)
2006-10-17 05:41 UTC, Rub
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rub 2006-10-17 00:01:14 UTC
When loading xml jtl into the summary report listener the thoughput is
incorrect. The problem is caused by SampleResultConverter.java. When it creates
SampleResults  from the xml input it sets the startTime of the sampleResult to
the current time of the machine not to the actual timestamp stated in the xml as
the old jtl file format parser does. 

The actual conflicts comes from the SampleResultConverter.retrieveAttributes
method when it makes the call to SampleResult.setTime(). This call doesn't allow
to specify the startTime so the starttime is set to (System.currentTimeMillis()
- elapsed).
Comment 1 Rub 2006-10-17 03:03:08 UTC
Created attachment 19011 [details]
svn patch file for files SampleResult.java and SampleResultConverter.java

Uses the timestamp of the sample for startTime. Previous version used current
time on the machine leading to wrong throughput calculations
Comment 2 Rub 2006-10-17 05:41:01 UTC
Created attachment 19013 [details]
svn patch file for files SampleResult.java and SampleResultConverter.java

same as Attachment #19011 [details] but without changing method signatures.
Comment 3 Sebb 2006-10-20 16:35:03 UTC
Thanks.

The code in SVN branch 2.2 has been fixed, and is in the nightly build:

2-2.20061020