Bug 40614 - java.io.FileNotFoundException when editing page
java.io.FileNotFoundException when editing page
Status: RESOLVED DUPLICATE of bug 33966
Product: Lenya
Classification: Unclassified
Component: Default Publication
1.2.4
PC All
: P2 major
: 1.2.5
Assigned To: Lenya Developers
:
Depends on: 33966
Blocks:
  Show dependency tree
 
Reported: 2006-09-27 09:24 UTC by Taras Yura
Modified: 2007-03-21 21:37 UTC (History)
1 user (show)



Attachments
Log4j file (16.20 KB, text/plain)
2006-09-28 07:36 UTC, Taras Yura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Taras Yura 2006-09-27 09:24:48 UTC
If i'm trying to access any editor in authoring area, i'm receiving Generic
Excepton:
Reason: java.io.FileNotFoundException:
C:\Documents%20and%20Settings\taras.yura\downloads\lenya_cocoon\apache-lenya-1.2.4-src\build\lenya\webapp\lenya\pubs\default\content\rcml\content\authoring\index\index_en.xml.rcml
(The system cannot find the path specified)
Check the log files.
File name:	\content\authoring\index\index_en.xml


This file is created and accessible:
<?xml version="1.0" encoding="UTF-8"?>
<XPSRevisionControl>
<CheckIn>
<Identity>System</Identity>
<Time>1159347830903</Time>
</CheckIn>
</XPSRevisionControl>

The similar problem is described here:
http://marc2.theaimsgroup.com/?l=lenya-user&m=113972617312452&w=2

I'm using Java 1.5.0_08-b03, Cocoon 2.1.9, Xalan 2.7.0

Also, i have a problem described in 33966 bug
Comment 1 Taras Yura 2006-09-28 07:36:56 UTC
Created attachment 18926 [details]
Log4j file
Comment 2 Andreas Hartmann 2006-12-12 06:04:02 UTC
Just a wild guess - maybe it's related to the spaces in your installation path?
Comment 3 Catalin Hritcu 2006-12-30 01:55:57 UTC
I have the same problem. Clean install on a Mac, no spaces in the path, and when I start "./lenya.sh 
servlet" and try to edit anything I get this:

Generic Exception
Reason: java.io.FileNotFoundException: file:/Users/hritcu/JavaApps/apache-lenya-1.2.4-bin/build/
lenya/webapp/lenya/pubs/default/content/rcml/content/authoring/index/index_en.xml.rcml (No such 
file or directory)
Check the log files.

File name:	/content/authoring/index/index_en.xml

This happens both with the source and the binary distribution.
Comment 4 Catalin Hritcu 2006-12-30 02:41:06 UTC
This is most likely a duplicate of 33966, sorry. I checked and my problem does not appear in the current 
lenya 1.2.x branch.
Comment 5 jann forrer 2007-01-09 02:35:41 UTC
I can not reproduce this bug with current 1.2.x

The last entry for this bug seems to indicate that we can close it. 
WDYT?
Comment 6 Antonio Gallardo 2007-03-21 21:37:00 UTC


*** This bug has been marked as a duplicate of 33966 ***