Bug 40103 - extraneous closing tag in LDAP Extended result tree
extraneous closing tag in LDAP Extended result tree
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.2
PC Windows XP
: P4 minor (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 40635 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-07-24 12:43 UTC by mark connolly
Modified: 2007-07-02 05:29 UTC (History)
1 user (show)



Attachments
Patch for problem, with other enhancements (50.33 KB, patch)
2006-08-23 19:22 UTC, Dolf Smits
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mark connolly 2006-07-24 12:43:32 UTC
In a search test, the result tree contains an extraneous closing operation tag.
 This prevents the parser from displaying the result as XML.

For example: in the following, the </operation> following </searchresult> should
not exist.

<ldapanswer>
    <operation>
        <opertype>search</opertype>
        <searchfilter>(samaccountname=example)</searchfilter>
        <searchbase>ou=bcbsnc users,dc=bcbsnc,dc=com</searchbase>
        <scope>2</scope>
        <countlimit>0</countlimit>
        <timelimit>0</timelimit>
    </operation>
    <searchresult>
        <dn>CN=example,ou=excample,dc=example,dc=com</dn>
        <returnedattr>1</returnedattr>
        <attribute>
            <attributename>displayName</attributename>
            <attributevalue>John Smith</attributevalue>
        </attribute>
    </searchresult>
    </operation>
    <responsecode>0</responsecode>
    <responsemessage>Success</responsemessage>
</ldapanswer>
Comment 1 Dolf Smits 2006-08-23 19:22:50 UTC
Created attachment 18747 [details]
Patch for problem, with other enhancements

This is a patch, made against the svn trunk from 3 days ago.
It will solve this problem, has some extra features added and some changes to
the userInterface.
a patch for the manulas is still to be made :-(
Comment 2 Sebb 2006-08-23 20:15:21 UTC
Thanks very much!

By the way, SVN trunk is rather out of date - 2.2 is built from branch/rel-2-2 -
or is that what you meant?

But I expect the patch can be made to work against the branch anyway.
Comment 3 Peter Lambrechtsen 2006-09-29 00:58:50 UTC
*** Bug 40635 has been marked as a duplicate of this bug. ***
Comment 4 Sebb 2007-03-11 10:55:21 UTC
The patches did not seem to work properly, even against the revision quoted in 
them; however I think it has all now been committed OK.

Please try the nightly build (any after r516970)

[Note that I combined the bind & sbind panels, as sbind needed all the bind 
variables anyway]
Comment 5 Sebb 2007-07-02 05:29:35 UTC
No problems reported, so assuming fixed