Bug 39773 - NTLM Authenication passes NULL as Host
NTLM Authenication passes NULL as Host
Status: RESOLVED WORKSFORME
Product: JMeter
Classification: Unclassified
Component: HTTP
Nightly (Please specify date)
All Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 40178 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-06-10 13:00 UTC by Jason Bowling
Modified: 2006-09-16 16:50 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Bowling 2006-06-10 13:00:11 UTC
In the class file org.apache.jmeter.protocol.http.sampler.HTTPSampler2 the
method "setConnectionAuthorization" attempts to create an instance of
NTCredentials and passes in NULL for the Host parameter.  This causes the
NTCredentials to throw an argument null exception.  This parameter should be the
computer name the request is originating from.  Once you pass in the computer
name, the NTLM auth works. 

This error exists in Nightly Build 2006-06-08 and in the RC1 for 2.1.2.
Comment 1 Sebb 2006-06-10 14:10:51 UTC
The original code was created for httpclient 2.0.2; it seems the latest code has
added the null checks...

Would "localhost" do?
Comment 2 Sebb 2006-06-10 14:31:08 UTC
[Forget localhost]

I've made a change and built 2-1.20060610 in the nightly dir - it would be very
helpful if you could check if this fixes the problem, so it can go into the next
release.
Comment 3 Jason Bowling 2006-06-10 14:52:54 UTC
I've downloaded the 2006.06.10 build and the localHost fix worked great with my
test plan.  Thank for the quick action!
Comment 4 Sebb 2006-09-16 23:50:28 UTC
*** Bug 40178 has been marked as a duplicate of this bug. ***