Bug 39179 - FarmWarDeployer does not deploy ".war" correctly
FarmWarDeployer does not deploy ".war" correctly
Status: RESOLVED DUPLICATE of bug 39178
Product: Tomcat 5
Classification: Unclassified
Component: Catalina:Cluster
5.5.12
Other other
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-04-01 14:23 UTC by Tim Lucia
Modified: 2006-04-01 06:52 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lucia 2006-04-01 14:23:35 UTC
(see also 31978) (Per Filip's request)

The FarmWarDeployer does not correctly deploy a war named (only) ".war".  I get
the following error (Missing application web.xml, using defaults only) in my
tomcat_console.log:

2006-04-01 08:18:05,355 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO  Diagnostics
: Stopping application 'My Application' at Sat Apr 01 08:18:05 EST 2006
2006-04-01 08:18:05,359 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO licationLifecycleListener : Application context destroyed. 2006-04-01
08:18:05,381 [ContainerBackgroundProcessor[StandardEngine[Catalina]]] INFO 
ContextConfig
: Missing application web.xml, using defaults only
StandardEngine[Catalina].StandardHost[localhost].StandardContext[/]
2006-04-01 08:18:25,397 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO  WarWatcher
: check cluster wars at /tmp/war-listen

Note that the previous context running on / was stopped and replaced by this new
one.

OK - Listed applications for virtual host localhost
/admin:running:0:/usr/local/tomcat/server/webapps/admin
/:running:0:
/log4jconfig:running:0:log4jconfig
/:stopped:0:ROOT /manager:running:0:/usr/local/tomcat/server/webapps/manager

If I undeploy the application running as / (from ".war") then the webapp
directory (appBase of the host) IS DELETED!  (Ooops)

Tim Lucia
Comment 1 Peter Rossbach 2006-04-01 14:52:27 UTC

*** This bug has been marked as a duplicate of 39178 ***