Bug 38836 - java.io.IOException when reading data
java.io.IOException when reading data
Status: RESOLVED DUPLICATE of bug 38346
Product: Tomcat 5
Classification: Unclassified
Component: Servlet & JSP API
5.5.12
PC Linux
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-03-03 02:39 UTC by Mario Camou
Modified: 2007-06-01 19:09 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Camou 2006-03-03 02:39:11 UTC
I have an application that sends data to a servlet. It sends a data file, usually 100 lines where each line 
is 116 characters long.

I am getting the following exception. It does not occur all the time, but it seems to occur when the 
server is especially loaded:

java.io.IOException
        at org.apache.catalina.connector.InputBuffer.reset(InputBuffer.java:439)
        at org.apache.catalina.connector.CoyoteReader.reset(CoyoteReader.java:133)
        at org.apache.catalina.connector.CoyoteReader.readLine(CoyoteReader.java:190)
        at mx.com.cie.tarificador.parser.Receiver.receive(Receiver.java:87)

(mx.com.cie.tarificador.parser.Receiver.receive is a method I call from the doGet and doPost servlet 
methods to do the receiving and parsing of the file).

Note that this is not a dupe of bug #34829 since in this case the error occurs even though the line is 
116 characters long.
Comment 1 Mario Camou 2006-03-03 02:47:48 UTC
I cannot test on 5.5.15 because of bug #38835. I also cannot test on 5.5.14 because this is happening on 
a productions system and bug #34829 affects it.
Comment 2 Rainer Jung 2006-03-03 21:42:11 UTC
This might be a duplicate of
http://issues.apache.org/bugzilla/show_bug.cgi?id=38346 which has already been
fixed in HEAD. The patch will be included in 5.5.16 which will be released in
the next days. Please give feedback, if 5.5.16 fixes your problem.

You also refer to 34829. That might have been fixed by the same patch.
Concerning 38835 please see the comment bei William Barker there.
Comment 3 Mario Camou 2006-03-04 03:45:36 UTC
Tested on 5.5.15 and the problem is still there. It is intermittent, it doesn't happen all the time and it 
might happen on one request and not happen on another one just like it. I will test on 5.5.16 as soon as 
it's out.
Comment 4 Mark Thomas 2007-06-01 19:09:31 UTC
No further comments from OP. Assuming it was a duplicate and is now fixed.

*** This bug has been marked as a duplicate of 38346 ***