Bug 37960 - Update site generation to Velocity 1.4
Update site generation to Velocity 1.4
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Other
1.3alpha
Other other
: P2 normal
: ---
Assigned To: log4j-dev
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-12-19 18:35 UTC by Curt Arnold
Modified: 2006-09-13 15:12 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Curt Arnold 2005-12-19 18:35:02 UTC
The site generation has used a development build of Velocity 1.4 for several
years.  This enhancement updates the log4j build to use the release version of
Velocity 1.4 and eliminates the dependency on logging-site.

To generate the site, download Velocity-1.4 from http://jakarta.apache.org and
JDOM beta 8 from http://www.jdom.org/dist/binary/archive.  Velocity-1.4 is not
compatible with JDOM 1.0 due to package name changes in JDOM that occurred after
beta 8.  Unzip and specify velocity.jar and jdom.jar per build.properties.sample.
Comment 1 Curt Arnold 2005-12-19 18:35:56 UTC
Committed revision 357730.
Comment 2 Curt Arnold 2006-09-13 22:12:53 UTC
Fixed in v1_2-branch at rev 443145.